Overblog Suivre ce blog
Editer l'article Administration Créer mon blog

FONCTION SI IMBRIQUEE

3 Octobre 2006 , Rédigé par yourxl Publié dans #FONCTION

La fonction SI() n'autorise que 2 réponses possibles. Lorsqu’on a un problème à résoudre avec 3 réponses possibles, il faudra procéder par élimination en utilisant, successivement, 2 fonctions SI(). Les 2 fonctions seront imbriquées.

 

=SI(test_logique1;valeur_si_vrai ; SI(test_logique2 ; valeur_si_vrai2 ; valeur_si_faux2))

La 2ème fonction SI(), qui est représentée en bleue, s'exécutera si (et seulement si) la réponse au test_logique1, qui est représenté en rouge,  est "FAUX".

Prenons un exemple tout simple :

Si la cellule A1<32 (rappel : A1 représente la référence de cellule colonne A et ligne 1) alors la cellule B2 est égal à « faible » ; si A1<65 alors la cellule B2 est égal à « moyen » ; si A1>64 alors la cellule B2 est égal à « haut ».

Syntaxe Excel :

=Si (A1<32 ; B2 = «faible» ; si (A1<65 ; B2 = « moyen » ; « haut »)

Maintenant à vous de jouer en téléchargeant l’exercice ci-dessous :



Les exemples de formules utilisés dans cet exercice vous serviront inévitablement dans vos applications Excel :

·        Ne rien inscrire lorsque la cellule prend une valeur « nulle »

·        Si le test est vrai, inscrire la valeur voulue ou inscrire une autre valeur.

Ces exemples de formules avec la fonction SI que vous venez d’étudier, représentent les prémices des utilisations de base des fonctions que nous allons voir au fur à mesure des articles.


Essayez d’utiliser ces exemples dans vos applications et en cas de problème, saisissez un commentaire pour que je puisse vous aidez.


C’est la seule manière de pouvoir progresser intelligemment.

Partager cet article

Repost 0

Commenter cet article

Yan 02/10/2010 16:58



404 not found pour l'exercice , dommage.



dada 04/03/2009 17:45

Bonjour,
je souhaite modéliser un tableau de coût de transport. Les coûts sont calculé en fonction du poids de la marchandise. Chaque groupe de prix se fait donc en fonction d'une tranche/ catégorie de poids.Borne inférieure et supérieure.J'essaie de modéliser ce tableau avec des formules SI imbriquées.Mon problème et qu'excel bloque au deuxième membre de ma fonction et applique le taux O,7 à tous les poids supérieurs à 45 KG.Voici le tableau :        Kg     -45      45     100      300      500     1000Taux  1,00   0,70   0,50     0,45    0,40      0,35
Voici la formule que j'ai écrit : =SI(E8E8>=45;E8*0,7;SI(300>E8>=100;E8*0,5;SI(500>E8>=300;E8*0,45;SI(1000>E8>=500;E8*0,4;SI(E8>=1000;E8*0,35))))))
Merci de m'aider sur l'erreur de synthaxe dans la formule ou de me proposer une autre formule.

Martine 02/07/2008 22:13

salut interressant ton site!je le garde en favori pour m'aider même si pour l'instant je nage encore ...bonne continuation

steven 11/11/2006 21:23

tres intéréssant cette méthode avec la fonction si.
merci pour l'info
bonne continuation

yourxl 12/11/2006 10:10

merci pour le commentaire.ce qui est important pour moi ce sont des commentaires comme le votre qui m'indique l'utilité et la véracité du théme abordé dans mes articles.a bientôtyourxl